[arm64]在银河麒麟v10 SP1中安装UOS版deepin-wine微信

@Ta 2021-10-08发布,07-21 13:26修改 11605点击

目测只兼容银河麒麟V10 SP1和后续版本,可能不兼容老的V10版本。
安装包转换工具:https://hu60.cn/q.php/bbs.topic.101335.html

安装方法

安装依赖

请先打开终端,执行以下命令安装所需依赖:

sudo apt update
sudo apt install zenity p7zip-full fonts-wqy-microhei fonts-noto-cjk

然后再根据CPU的不同选择下面的一个安装方法:

非鲲鹏CPU

目测只兼容银河麒麟V10 SP1和后续版本,可能不兼容老的V10版本。

请依次安装这些包:

  1. com.deepin-wine-runtime.deepin_1.0deepin2-tigermod_arm64.deb(87.46 MB)

  2. com.deepin-box86.deepin_0.2.3deepin12_arm64.deb(3.59 MB)

  3. com.deepin-wine6-stable.deepin_6.0deepin14_arm64.deb(36.67 MB)

  4. com.qq.weixin.deepin_3.3.0.115deepin23_arm64.deb(170.9 MB)

鲲鹏CPU

请依次安装这些包:

  1. deepin-wine-exagear-images_10deepin2_arm64.deb(306.47 MB)

  2. com.deepin-wine-runtime.deepin_1.0deepin2-tigermod_arm64.deb(87.46 MB)

  3. com.deepin-box86.deepin_0.2.3deepin12_arm64.deb(3.59 MB)

  4. com.deepin-wine6-stable.deepin_6.0deepin14_arm64.deb(36.67 MB)

  5. com.qq.weixin.deepin_3.3.0.115deepin23_arm64.deb(170.9 MB)


新版,尚未测试

  1. deepin-wine-exagear-images_10deepin4_arm64.deb(363.43 MB)

  2. com.deepin-wine-runtime.deepin_1.0deepin2-tigermod_arm64.deb(87.46 MB)

  3. com.deepin-box86.deepin_0.2.3deepin22_arm64.deb(64.48 MB)

  4. com.deepin-wine6-stable.deepin_6.0deepin31_arm64.deb(25.51 MB)

  5. com.qq.weixin.deepin_3.3.0.115deepin32_arm64.deb(182.72 MB)

回复列表(18)
  • @Ta / 2021-10-08 / /

    @老虎会游泳,树莓派能玩?我要试试

    一加7pro(皇帝版)
  • @Ta / 2021-10-08 / /

    @5258,应该能安装,能不能启动我就不知道了。要用64位系统,32位系统装不上。

  • @Ta / 2021-10-08 / /

    @老虎会游泳,我试一下,然后你就知道结果了
    一加7pro(皇帝版)

  • @Ta / 2021-10-08 / /

    @老虎会游泳,很遗憾的告诉你,打不开。
    一加7pro(皇帝版)

  • @Ta / 2021-10-08 / /

    @5258,好吧

  • @Ta / 2021-10-08 / /

    @老虎会游泳,而且直接死机了
    一加7pro(皇帝版)

  • @Ta / 2021-10-08 / /

    建议大家的树莓派不要试,压根打不开,只要你手贱点打开树莓派就直接卡死了
    一加7pro(皇帝版)

  • @Ta / 2021-10-08 / /

    什么应用都打不开了
    一加7pro(皇帝版)

  • @Ta / 2021-10-08 / /

    更新:@5258 最后还是打开了微信。树莓派在首次打开微信的过程中非常卡,是因为它CPU性能太弱,而微信首次启动时有一个解压的步骤非常消耗CPU资源。

    44b487f22e97880b.png

  • @Ta / 2021-10-08 / /

    微信可能会弹出在线升级,升级后如果不能用,就删除~/.deepinwine隐藏文件夹,然后重新打开微信,就会重新解压,回到初始版本。

  • @Ta / 2021-10-08 / /

    树莓派上的已知问题:

    • 首次启动特别卡。
    • 截屏不能用,截出来的内容是纯黑。
    • 视频看不到画面,显示为纯黑。但是@5258 表示:拖动窗口的时候能看到一点画面。
      1f95e12acb60b750.png
  • @Ta / 2021-10-08 / /

    所有arm64上的已知问题:偶尔不能打字,需要等很久才能恢复,或者必须结束进程重开。

  • @Ta / 2021-10-12 / /

    以下deb仅供测试,不能正常使用:
    com.qq.wxworklocal.deepin_2.4.60100.14_arm64.deb(98.32 MB)

  • @Ta / 2021-11-07 / /
    @老虎会游泳  我的是麒麟v10系统,飞腾FT-2000/4(64位,4核)芯片,装上以后启动不了。能发个SP1的链接吗?谢谢!
  • @Ta / 2021-12-17 / /

    @初心前行,在这里填写信息提交就能下载
    https://www.kylinos.cn/support/trial.html

  • @Ta / 2021-12-29 / /
    麒麟990成功安装下这个微信,谢谢兄弟,想问一下还有没有QQ的?
  • @Ta / 01-18 08:50 / /
    飞腾FT-2000/4(64位,4核)SP1安装信赖包时出现:dpkg: 处理软件包 deepin-elf-verify (--configure)时出错:
     已安装 deepin-elf-verify 软件包 post-installation 脚本 子进程被信号(已终止) 终
    止了
    dpkg: 依赖关系问题使得 com.deepin-wine6-stable.deepin 的配置工作不能继续:
     com.deepin-wine6-stable.deepin 依赖于 deepin-elf-verify (>= 0.0.16.7-1);然而:
      软件包 deepin-elf-verify 尚未配置。

    dpkg: 处理软件包 com.deepin-wine6-stable.deepin (--configure)时出错:
     依赖关系问题 - 仍未被配置
    dpkg: 依赖关系问题使得 com.deepin-wine-runtime.deepin 的配置工作不能继续:
     com.deepin-wine-runtime.deepin 依赖于 deepin-elf-verify (>= 0.0.16.7-1);然而:
      软件包 deepin-elf-verify 尚未配置。

    dpkg: 处理软件包 com.deepin-wine-runtime.deepin (--configure)时出错:
     依赖关系问题 - 仍未被配置
    dpkg: 依赖关系问题使得 com.box86.deepin 的配置工作不能继续:
     com.box86.deepin 依赖于 deepin-elf-verify (>= 0.0.16.7-1);然而:
      软件包 deepin-elf-verify 尚未配置。

    dpkg: 处理软件包 com.box86.deepin (--configure)时出错:
     依因为错误消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。
                                                                           因为错误
    消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。
                                                                由于已经达到 MaxRepo
    rts 限制,没有写入 apport 报告。
                                    赖关系问题 - 仍未被配置
    在处理时有错误发生:
     deepin-elf-verify
     com.deepin-wine6-stable.deepin
     com.deepin-wine-runtime.deepin
     com.box86.deepin
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    请问是怎么回事?,我是小白。
  • @Ta / 07-21 13:10 / /

    @jonny,你安装的不是从我这里获取的deb,从我这里获取的deb不会出现这种提示。

    如果你从其他渠道获取了deb,需要使用这个脚本进行转换才能安装:
    https://hu60.cn/q.php/bbs.topic.101335.html

添加新回复
回复需要登录